B618 verliert Carrier Aggregation nach einiger Zeit komplett

BlueKingMuch

Mobilfunk Teilnehmer
30 Nov 2016
63
29
Hallo!

ich habe ein ziemlich seltsames Problem mit meinem Huawei B618.

Ich habe einen 250MBit Vertrag bei Magenta, dies konnte ich nachts bei funktionierenden CA auch schon (fast) beobachten (ca 220 max. Möglich).

Ich habe seit einiger Zeit jedoch immer das Problem, dass wenn das Modem eine Zeit lang eingeschalten ist, dass es offensichtlich die Fähigkeit für Carrier Aggregation verliert.

Überprüft habe ich dies mit der "Huawei Band Tools"; wo man dediziert Frequenzen auswählen kann.

Bei mir fixiert er nach einiger Zeit sich komplett auf die 800MHz Frequenz (B20), und ich kann nicht einmal mit Neustarts dieses Verhalten beheben.
Was ich dann höchstens machen kann, ist mit Band Tools auf Band 3 oder 7 zu wechseln, dort wird aber auch keine Carrier Aggregation mehr betrieben (es wird nie mehr 4G+ im Webinterface angezeigt).

Der einzige Workaround der mir meine Carrier Aggregation wieder zurückbringt, ist das flashen der ohnehin bereits auf dem Gerät vorhandenen aktuellsten Firmware (B618_UPDATE_11.198.01.00.965.BIN - hier aus dem Forum).

Dies funktioniert aber auch nur ca 12 Stunden, danach verliert er wieder diese Fähigkeit und fixiert sich erneut ins B20, und macht auch keine Anstalten von da zu wechseln.

Beispiel heute:

3x Speed tests, im Webinterface nur "4G":
https://www.speedtest.net/result/9840593554
https://www.speedtest.net/result/9840599375
https://www.speedtest.net/result/9840602670

danach habe ich einen Neustart Probiert, und danach nochmals 3 Speedtests gemacht, im Webinterface wieder nur "4G":

https://www.speedtest.net/result/9840610366
https://www.speedtest.net/result/9840613030
https://www.speedtest.net/result/9840615457

..dann der Workaround mit dem flashen der gleichen Firmware nochmals, plötzlich funktionierts wieder, gleichzeitig wird auch wieder "4G+" angezeigt:

https://www.speedtest.net/result/9840640710
https://www.speedtest.net/result/9840647537
https://www.speedtest.net/result/9840652601




Ich bin zunehmend etwas Ratlos was ich jetzt noch probieren könnte, denn jeden Tag die Firmware zu flashen ist dann doch etwas mühsam.

Hat jemand Ideen?

Danke im Voraus!

LG Michi
 

Evilc22

Mobilfunk Teilnehmer
18 Apr 2020
308
109
Schlechte Empfangswerte können dazu führen
B20 musst raus nehmen ansonsten macht der Router kein CA
B3 gibts bei A1 Interband CA oder wie man es so nennt

https://www.lteforum.at/mobilfunk/huawei-band-tool.7970/

oder Huactrl auf Android
Router auf B3 Fixieren
Band 20 brauchst nicht! zwischen B20 und B3 kann der Router kein CA machen bei A1 zumindest
 
Zuletzt bearbeitet:

BlueKingMuch

Mobilfunk Teilnehmer
30 Nov 2016
63
29
Verfügbar sind bei mir anscheinend alle 3 Frequenzen, das Problem ist jedoch wenn ich mit dem Band tool z.B B3+B7 einstelle, dann macht er dennoch kein CA.

Bei Magenta gibt's anscheinend auch CA mit dem B20 Band, also theoretisch kann ich B3+B7+B20 CA machen und vermute dass dies auch so passiert, weil ich ungefähr die Bandbreite habe nach einem frischen Flash wenn ich alle 3 Zusammenrechne.

Verzichten könnte ich wohl schon auf's B20 Band weil es komplett überbucht ist, jedoch löst das mein Grundlegendes Problem nicht, dass CA plötzlich wegfällt und ich den Speed gerne dauerhaft hätte, der nach dem flashen verfügbar ist für einige Stunden.

Gibt's alternativen? Soll ich mir nen anderen Router holen?
 

Evilc22

Mobilfunk Teilnehmer
18 Apr 2020
308
109
Hier gehts um Magenta....
verpeilt ..

Da musst eben schauen wenn Speed haben möchtest dass du auch 2100 rein bekommst
also 1800+2100

Router gleich auf 2100 fixieren und guten Aufstellungsort suchen
Ansonsten bleiben nur mehr Richtantennen
 

unknown

Mobilfunk Teilnehmer
15 Nov 2015
3.438
1.233
Interessant wäre, ob ein anderes Gerät an der gleichen Stelle CA permanent beibehält.

Bei Magenta gibt's anscheinend auch CA mit dem B20 Band, also theoretisch kann ich B3+B7+B20 CA machen und vermute dass dies auch so passiert, weil ich ungefähr die Bandbreite habe nach einem frischen Flash wenn ich alle 3 Zusammenrechne.
Der B618 kann kein 3CA.
 

Evilc22

Mobilfunk Teilnehmer
18 Apr 2020
308
109
Ich habe gestern einen anderen Masten angepeilt
Der B535 verliert einfach CA und das lässt sich nur durch einen neustart beheben
Gegenüber anderen Masten ist der SINR nicht so gut 2-4 statt 5-10
 

BlueKingMuch

Mobilfunk Teilnehmer
30 Nov 2016
63
29
Ich habe mal ein wenig bind dem Huawei Band Tool herumgespielt.

Ich habe gerade alle Frequenzen durchprobiert: 800(B20), 1800(B3), 2100(B1), 2600 (B7) im Magenta Netz.

Zuerst mal Speedtests von den einzelnen Frequenzen:

B20:


Empfang: 5/5

...scheidet aus wegen Überbuchung.

B3:


Empfang: 5/5


B1:


Empfang: 5/5

B7:


Empfang: 3/5


...damit wäre ja die Basis vorhanden. Nun gehe ich Verschiedene CA modis durch zwischen B3, B7, und B1.

B1+B3:


Anmerkung: 4G+ wird angezeigt, also CA.


B1+B7:


Anmerkung: 4G wird angzeigt, also kein CA.

B3+B7:


Anmerkung: 4G wird angezeigt, also kein CA.


wie angemerkt wurde, der B618 kann wirklich nur 2CA, war ein Irrtum von mir. Verwende nun in Zukunft B1+B3, mal sehen wie stabil das läuft.

Bringt mich aber zu einer weiteren Frage: wär bei mir ein Upgrade zum B715/B818 vielleicht eine überlegung?
Die Idee wär ja alle Frequenzen die man hat zu nutzen.
 
Zuletzt bearbeitet:

unknown

Mobilfunk Teilnehmer
15 Nov 2015
3.438
1.233
Im Prinzip kann es mit einem B818 nur besser werden (Zum B715 kann ich nichts sagen). Vielleicht besitzt du ein Handy, welches 3CA mit den entsprechenden Frequenzen kann. Dann kannst du schon einmal ein wenig rumprobieren.

Ist B20 womöglich ein anderer Sender?
 

BlueKingMuch

Mobilfunk Teilnehmer
30 Nov 2016
63
29
Im Prinzip kann es mit einem B818 nur besser werden (Zum B715 kann ich nichts sagen). Vielleicht besitzt du ein Handy, welches 3CA mit den entsprechenden Frequenzen kann. Dann kannst du schon einmal ein wenig rumprobieren.
Hab ein Google Pixel 3a, kann laut Data sheet 3CA (nur welche Kombinationen genau weiß ich nicht), unterstützt alle hier getesteten Frequenzen.

ich hab damit ein paar Speedtests gemacht, jedoch macht das Pixel offensichtlich kein CA bei mir. entweder ich erwische B20 mit ~3 MBit/s Down, oder B3 mit ca 60-70 MBit/s Down. Mehrere Neustarts sowie Flugmodus probiert, unter Freien Himmel.

Zusatz: bei allen Tests kein "LTE+ oder 4G+" oben in der Status-Bar, nur "LTE". Ich meine aber schon ein paar mal 4G+ gesehen zu haben, also Prinzipiell kann das Handy CA.

ich weiß halt nur nicht wie ich mein Handy "überreden" kann CA zu betreiben.

Ist B20 womöglich ein anderer Sender?
Wenn du mir sagst, woran ich das erkennen kann, dann kann ich das auch sagen :D
 
Zuletzt bearbeitet:

sarasota

Mobilfunk Teilnehmer
17 Mai 2020
17
19
Hallo
Für Android gibt es zB HuaCtrl - da siehst Du die Cellidentifier.
Dann auf der Webseite von cellmapper.net siehst Du an welchen Masten bzw. mit welcher Zelle dein B618 verbunden ist.
Hab ich heute auch zum ersten mal gemacht und herausgefunden, daß ich wenn ich Band 20 800MHz "aussperre" mit B3 1800MHz statt 6 mbit gleich mal bis zu 80 mbit down und 30up zusammenbringe. (Bob/A1)
Kannte ich noch nicht weil früher im 3 Netz CA mit 1800 + 2100 bestens funktioniert hat und kein B20 vorhanden ist.

Gruß sarasota