CAT-6 Module Basteleien

Iridium

Mobilfunk Teilnehmer
13 Jan 2019
72
27
Im letzten Patch von dnsmasq in OpenWrt (2.80) hatte ich gemerkt dass der include poll.h korrigiert wurde:
patch.PNG

Im make file habe ich CC = gcc beigefügt.

Und das wars, ich hatte aber noch einige Warnmeldungen, aber die binaries wurden generiert.
Leider habe ich jetzt gemerkt dass der dnsmasq service in OpenWrt nicht startet. Ob der Fehler jetzt im binary liegt oder eine config Datei habe ich noch nicht nachgeschaut in den logs.

Ich habe das Problem dass mein EM7565 auch nicht mehr richtig funktioniert (der serial port antwortet nicht, weder unter Linux, weder unter Windows,... vid/pid 1199:9091)
 

Blaubeere

Mobilfunk Teilnehmer
13 Dez 2015
757
275
Die eingecheckte Version auf GitHub ist 2.76.
Anhand der Kommentare im Code (dhcp.c) siehst du welche checks du deaktivieren musst. Falls benötigt, kann ich dir auch ein patch-file machen.
 

Iridium

Mobilfunk Teilnehmer
13 Jan 2019
72
27
Ah der dnsmasq service ist gestartet. Hatte die user rights an der /etc/init.d/dnsmasq Datei vergessen einzustellen...

Moment mal...
Capture.PNG


Wieso startet der mir udhcpc anstatt von dnsmasq???
 

nevusZ

Mobilfunk Teilnehmer
24 Nov 2017
32
4
brauch eure Hilfe, bekomme LTECA nicht hin mit dem em7455
habe den Provider gewechselt Drei -> A1
Weil bei Drei kein B7 verfügbar war nur B3 (also keine CA vom Provider verfügbar, was mich ein wenig wundert im Süd-Westen von Graz?!)
Bei A1 (educom) bekomme ich jetzt mit B7 und B20 ins Netz aber nicht mit beiden. Bei LTA CA state steht immer NOT ASSIGNED
Hat jemand eine Idee? Hier meine Logs:
Code:
root@OpenWrt:~# mmcli -m 0
  --------------------------------
  General  |            dbus path: /org/freedesktop/ModemManager1/Modem/0
           |            device id: 20ca4a9a27e45848d0ee61999771fa998933d9fc
  --------------------------------
  Hardware |         manufacturer: Sierra Wireless, Incorporated
           |                model: EM7455
           |    firmware revision: SWI9X30C_02.33.03.00 r8209 CARMD-EV-FRMWR2 2019/08/28 20:59:30
           |       carrier config: default
           |         h/w revision: 1.0
           |            supported: gsm-umts, lte
           |              current: gsm-umts, lte
           |         equipment id: 123456789012345
  --------------------------------
  System   |               device: /sys/devices/platform/1e1c0000.xhci/usb2/2-1
           |              drivers: qcserial, qmi_wwan
           |               plugin: Sierra
           |         primary port: cdc-wdm0
           |                ports: ttyUSB0 (qcdm), ttyUSB1 (gps), ttyUSB2 (at),
           |                       cdc-wdm0 (qmi), wwan0 (net)
  --------------------------------
  Numbers  |                  own: 1234567890123
  --------------------------------
  Status   |                 lock: sim-pin2
           |       unlock retries: sim-pin (3), sim-pin2 (3), sim-puk (10), sim-puk2 (10)
           |                state: connected
           |          power state: on
           |          access tech: lte
           |       signal quality: 92% (recent)
  --------------------------------
  Modes    |            supported: allowed: 3g; preferred: none
           |                       allowed: 4g; preferred: none
           |                       allowed: 3g, 4g; preferred: 3g
           |                       allowed: 3g, 4g; preferred: 4g
           |              current: allowed: 3g, 4g; preferred: 4g
  --------------------------------
  Bands    |            supported: utran-1, utran-3, utran-4, utran-5, utran-8, utran-2,
           |                       eutran-1, eutran-2, eutran-3, eutran-4, eutran-5, eutran-7, eutran-8,
           |                       eutran-12, eutran-13, eutran-20, eutran-25, eutran-26, eutran-41
           |              current: eutran-7, eutran-20
  --------------------------------
  IP       |            supported: ipv4, ipv6, ipv4v6
  --------------------------------
  3GPP     |                 imei: 123456789012345
           |          operator id: 23201
           |        operator name: educom
           |         registration: home
  --------------------------------
  3GPP EPS | ue mode of operation: csps-2
  --------------------------------
  SIM      |            dbus path: /org/freedesktop/ModemManager1/SIM/0
  --------------------------------
  Bearer   |            dbus path: /org/freedesktop/ModemManager1/Bearer/0
root@OpenWrt:~# mmcli -m 0 --command=AT!LTECA=?
response: '!LTECA=<flag>
<flag>: 0 - disable CA
        1 - enable CA'
root@OpenWrt:~# mmcli -m 0 --command=AT!LTECA?
response: 'Hardware:
LTEB1: B8,
LTEB2: B2, B5, B12, B29,
LTEB3: B7, B20,
LTEB4: B4, B5, B12, B13, B29,
LTEB5: B2, B4, B30,
LTEB7: B3, B7, B20,
LTEB8: B1,
LTEB12: B2, B4, B30,
LTEB13: B4,
LTEB20: B3, B7,
LTEB25:
LTEB26:
LTEB29:
LTEB30: B5, B12,
LTEB41: B41,

Permitted Bands:
LTEB1: B8,
LTEB2: B2, B5, B12,
LTEB3: B7, B20,
LTEB4: B4, B5, B12, B13,
LTEB5: B2, B4,
LTEB7: B3, B7, B20,
LTEB8: B1,
LTEB12: B2, B4,
LTEB13: B4,
LTEB20: B3, B7,
LTEB25:
LTEB26:
LTEB41: B41,

Prune_ca_combos:
Empty'
root@OpenWrt:~# mmcli -m 0 --command=AT!GSTATUS?
response: '!GSTATUS:
Current Time:  38735            Temperature: 51
Reset Counter: 4                Mode:        ONLINE
System mode:   LTE              PS state:    Attached
LTE band:      B7               LTE bw:      20 MHz
LTE Rx chan:   2850             LTE Tx chan: 20850
LTE CA state:  NOT ASSIGNED
EMM state:     Registered       Normal Service
RRC state:     RRC Connected
IMS reg state: No Srv

PCC RxM RSSI:  -80              RSRP (dBm):  -123
PCC RxD RSSI:  -57              RSRP (dBm):  -91
Tx Power:      --               TAC:         1DBF (7615)
RSRQ (dB):     -16.2            Cell ID:     00038B01 (232193)
SINR (dB):      0.6'

root@OpenWrt:~# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
64 bytes from 8.8.8.8: seq=0 ttl=53 time=45.864 ms
64 bytes from 8.8.8.8: seq=1 ttl=53 time=81.301 ms
64 bytes from 8.8.8.8: seq=2 ttl=53 time=41.280 ms
^C
--- 8.8.8.8 ping statistics ---
4 packets transmitted, 3 packets received, 25% packet loss
round-trip min/avg/max = 41.280/56.148/81.301 ms
root@OpenWrt:~#

root@OpenWrt:~# mmcli -m 0 --command=AT!LTEINFO
response: '!LTEINFO:
Serving:   EARFCN MCC MNC   TAC      CID Bd D U SNR PCI  RSRQ   RSRP   RSSI RXLV
             2850 232  01  7615 00038B01  7 5 5   1 291 -14.6  -91.5  -58.4 --

IntraFreq:                                          PCI  RSRQ   RSRP   RSSI RXLV
                                                    291 -14.6  -91.5  -58.4 --
                                                    127 -18.3  -98.4  -68.7 --
                                                    388 -20.0 -103.7  -71.9 --

InterFreq: EARFCN ThresholdLow ThresholdHi Priority PCI  RSRQ   RSRP   RSSI RXLV

WCDMA:     UARFCN ThreshL ThreshH Prio PSC   RSCP  ECN0 RXLV'
root@OpenWrt:~#

root@OpenWrt:~# mmcli -V

mmcli 1.12.0
Copyright (2011 - 2019) Aleksander Morgado
License GPLv2+: GNU GPL version 2 or later <http://gnu.org/licenses/gpl-2.0.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

root@OpenWrt:~#


root@OpenWrt:~# mmcli -m 0 --command=AT!BAND?
response: 'Index, Name
11, B7+B20'
root@OpenWrt:~# mmcli -m 0 --command=AT!BAND=?
response: 'Index, Name
00, All bands
01, Europe 3G
02, North America 3G
06, Europe
07, North America
08, WCDMA ALL
09, LTE ALL
0A, B1
0B, B3
0C, B7
0D, B20
0E, B3+B7
0F, B1+B3
10, B1+B7
11, B7+B20'
root@OpenWrt:~#

root@OpenWrt:~# mmcli -m 0 --command=AT!BAND?
response: 'Index, Name
11, B7+B20'
root@OpenWrt:~# mmcli -m 0 --command=AT!BAND=?
response: 'Index, Name
00, All bands
01, Europe 3G
02, North America 3G
06, Europe
07, North America
08, WCDMA ALL
09, LTE ALL
0A, B1
0B, B3
0C, B7
0D, B20
0E, B3+B7
0F, B1+B3
10, B1+B7
11, B7+B20'
ich hatte mehrere Probleme
1 - die mhf4 pigtails waren nicht richtig drauf beim AUX anschluss (sind auch ziemlich fummelig zu montieren!!)
2 - falsche modemmanager version mit bug (https://github.com/openwrt/packages/issues/10565)
3 - hatte kurze zeit eine SMA Anschluss beim pigtail und eine RPSMA antenne (lässt sich super zusammenschrauben, hat aber 0 empfangsleistung :(

jetzt läuft alles - LTA CA B7+B20 A1 educom!

den Low Power Mode vom Lenovo gebrandeten modul habe ich jetzt auch wegbekommen:
https://www.lteforum.at/mobilfunk/cat-12-modul-sierra-airprime-em7565.8143/post-253940
Danke @Gsicht
 

Aktuelle Themen