Huawei E3372 & OpenWRT

reini122

Mobilfunk Teilnehmer
18 Dez 2014
11
2
Hallo,
hat es jemand geschafft, einen Huawei E3372 (ohne HiLink) in Kombination mit OpenWRT zum Laufen zu bringen?

Bei mir ist das Problem, dass das Modem zwar erkannt wird (also /dev/ttyUSB0 und /dev/ttyUSB1 sind da), jedoch versucht der Router bei "ifup wan" gar nicht erst, sich zu verbinden. Im log steht dann einfach nur:
"OpenWrt daemon.notice netifd: Interface 'wan' is now down"

Anfangs hat es aus welchem Grund auch immer versucht sich zu verbinden. Da kam er bis inkl. CONNECT und meine auch er sei verbunden, jedoch hat er die Verbindung danach automatisch wieder getrennt.

Hat hier jemand ein paar (config)-Tipps für mich?
 

Chrisss

Mobilfunk Teilnehmer
3 Dez 2014
110
36
Ich verwende das E3372 in der Hilink Version an einem NETGEAR WNDR3700 mit der aktuellen MultiWeb von hier.
Funktioniert Plug and Play.
 

Gsicht

Mobilfunk Teilnehmer
22 Mrz 2014
6.579
1.593
Code:
opkg install kmod-usb-net-cdc-eem kmod-usb-net-cdc-ether kmod-usb-net-cdc-mbim kmod-usb-net-cdc-ncm kmod-usb-net-cdc-subset kmod-usb-net-huawei-cdc-ncm
Für das NCM-Zeugs, die seriellen Interfaces hast du eh schon.

Dann:
Code:
echo -e "AT^NDISDUP=1,1,\"drei.at\"\r" > /dev/ttyUSB1
udhcpc -i wwan0
Dann bist du online.

Das WAN-Interface stellst du auf DHCP und das es "wwan0" verwenden soll.

Wenn du willst dass das Modem immer neu verbindet bei einer Trennung machst du folgendes:

Code:
crontab -e
* * * * * ash /home/connect.sh
einfügen.

Die connect.sh schaut so aus:
Code:
#!/bin/sh
echo -e "AT^NDISDUP=1,1,\"drei.at\"\r" > /dev/ttyUSB1
udhcpc -i wwan0
Die Methode ist nicht optimal, wird halt jede Minute der Befehl ausgeführt, führt aber nicht zur Trennung sollte das Modem aktuell verbunden sein. Außerdem siehst du nicht ob die Verbindung zwar besteht, aber keine Daten fließen (was bei mir aber noch nicht vorgekommen ist).
Die Alternative ist halt die Ping-Sache, aber davon bin ich nicht überzeugt.
 
  • Gefällt mir
Reaktionen: werna_werna und KOSH

Aktuelle Themen