K5005 unter OpenWrt?

LTE und 5G Antennen
24 März 2018
148
107
LEDE 17.01.4 auf einem TP-Link TL-MR3020 (v1.7) mit konfigurierter wwan Schnittstelle für einen E173…

Code:
config interface 'wan'
        option proto 'wwan'
        option apn 'webapn.at'
        option username 'BOFH'
        option password '1337'

Einfach den K5005 angesteckt und zack, das Ding war online. Ohne irgendwelche extra notwendigen Konfigurationsanpassungen oder zusätzlichen Pakete. Zum letzten Punkt muss ich allerdings anmerken, dass ich ein selbstgebautes Custom-Image verwende, wo alle eventuell nötigen Pakete bereits enthalten sind, siehe nachfolgender Code.

Code:
make image PROFILE=tl-mr3020-v1 PACKAGES="comgt kmod-usb-serial kmod-usb-serial-option kmod-usb-serial-wwan kmod-usb-acm usb-modeswitch chat kmod-mii kmod-usb-net kmod-usb-wdm kmod-usb-net-qmi-wwan uqmi kmod-usb-net-cdc-mbim umbim kmod-usb-serial-wwan"

Geschwindigkeit passt ebenfalls. Danke für euer zahlreiches Feedback zu dem Stick! :)

PS: Der LTE-Stick zieht übrigens ca. 0.07-0.46A (Ø 0.3A) bei 4.75V – falls es jemand wissen möchte.
 
Zuletzt bearbeitet:
24 März 2018
148
107
Jetzt habe ich doch noch eine Frage zu dem Stick: Ist es normal, dass der relativ heiß wird? Zwischen LED und Vodaphone Logo messe ich mit einem Infrarotthermometer bereits nach 10 Minuten Betriebsdauer regelmäßig über 52° am Plastikgehäuse. Bisher scheint es aber nicht zu schaden, ich konnte keine Beeinträchtigungen o.ä. feststellen. Der Wert kommt übrigens unabhängig vom verwendeten Hostgerät zustande. Die Signalstärke liegt bei 100%.

Wundert mich nur etwas, weil es derzeit noch nicht einmal Sommertemperaturen in den Räumlichkeiten hat… :D
 
24 März 2018
148
107
Kurzes Update noch zur Temperatur: Es werden sogar bis zu 64°, unabhängig vom 3G/4G Betriebsmodus. Wenn das Modem in den "Stromsparmodus" wechselt, sobald wenig bis gar keine Daten übertragen werden, kühlt er sich bald auf 38° ab. So oder so, abgefackelt ist er trotz Dauerbetrieb noch nicht. Na dann… :cool:

/EOD
 
24 März 2018
148
107
Ich muss diesen alten Thread noch einmal hervorholen… ;)

Ich wollte vorhin zum Test eine alte B-Free Breitband SIM-Karte (A5507XXX) in den Stick stecken. Diese Karten unterstützen bekanntlich kein LTE. Seltsamerweise kann ich mit dieser Karte beim K5005 auch über UMTS keine Verbindung herstellen. Über einen E173 klappt es problemlos. Hatte das Problem schon einmal jemand? Ich bin gerade etwas ratlos.

Code:
local2.info chat[3194]: ^M
local2.info chat[3194]: AT+CGDCONT=1,"IP","a1.net"^M^M
local2.info chat[3194]: OK
local2.info chat[3194]:  -- got it
local2.info chat[3194]: send (ATD*99***1#^M)
local2.info chat[3194]: expect (CONNECT)
local2.info chat[3194]: ^M
local2.info chat[3194]: ATD*99***1#^M^M
local2.info chat[3194]: CONNECT
local2.info chat[3194]:  -- got it
local2.info chat[3194]: send ( ^M)
daemon.info pppd[3192]: Serial connection established.
kern.info kernel: [  451.690000] wwan-wan: renamed from ppp0
daemon.info pppd[3192]: Using interface wwan-wan
daemon.notice pppd[3192]: Connect: wwan-wan <--> /dev/ttyUSB0
daemon.info pppd[3192]: CHAP authentication succeeded
daemon.notice pppd[3192]: CHAP authentication succeeded
daemon.notice pppd[3192]: Modem hangup
daemon.notice pppd[3192]: Connection terminated.

Andere [A1] SIM-Karten funktionieren in dem Stick ohne Probleme. Es macht auch keinen Unterschied, ob ich 3G oder WWAN in der OpenWrt-Konfiguration nutze.
 
22 März 2014
548
205
B.free - genug Guthaben drauf? Datenverbindung mit dem gewählten Tarif überhaupt möglich?
Hast du ein Android oder iPhone wo du die SIM reingeben kannst und über die A1-App schauen kannst, was mit der SIM "möglich" ist bzw. welche Datenoption (falls überhaupt) möglich ist?
 
24 März 2018
148
107
Ja, genug Guthaben bzw. Internet Package aktiviert. Mit einem 3G-Stick (E173, E220, …) funktioniert die gleiche SIM-Karte problemlos.

Sieht fast so aus, dass der K5005 mit den alten A55-Karten nicht klar kommt, selbst wenn er nur über UMTS einwählen soll.
 
24 März 2018
148
107
Sieht fast so aus, dass der K5005 mit den alten A55-Karten nicht klar kommt […]
Ich hatte heute die Chance eine neuere B-Free Breitband SIM-Karte von jemandem kurz zu testen.

Ergebnis: Funktioniert einwandfrei im K5005, egal ob über 3G oder 4G! :) (A5615XXX mit LTE-Unterstützung)

Liegt also wirklich an der alten A55-SIM-Karte. Und soweit ich weiß, tauscht A1 die nicht kostenlos… :rolleyes:
 
  • Gefällt mir
Reaktionen: the-mk