Magenta/UPC: Ipv6 Setup mit OpenWRT

laserjet313

Mobilfunk Teilnehmer
15 Aug 2019
3
0
liebe LTE community, ich komme aktuell mit folgendem vorhaben nicht weiter - es ist mir aber noch nicht ganz klar woher das problem kommt.

ziel:
Magenta (UPC) ipv6 und ipv4 internet mit eigenem OpenWRT Router dazwischen.

setup:
internet => upc connect box => open-wrt router (wan-port) => div. clients am LAN-port

problem:
connect box modem mode: IPV6 Only Funktioniert im modem-mode. jedoch funktioniert kein ipv4 via ds-lite
connect box im router mode: ipv4 funktioniert via ds-lite, ipv6 funktioniert nur am open-wrt router jedoch nicht auf clients, da sie keine v6 adresse bekommen.

vermutung:
router bekommt am WAN-port eine /128 IP sowie einen /64 prefix.
jedoch bekommt das LAN interface diesen prefix nicht weitergereicht (sollte es für DHCP-verteilung als auch RA bekommen)
im modem-mode erhält der router ein /57 prefix und das lan interface einen /64 zur weiteren verteilung an die clients.

Details:
UPC-Connect box (Arris Modem mit docsys3.1)
OpenWrt 18.06.2

/etc/config/network

Code:
config interface 'lan'
   option type 'bridge'
   option proto 'static'
   option ipaddr '192.168.11.1'
   option netmask '255.255.255.0'
   option gateway '192.168.11.1'
   option dns '192.168.11.1'
   option ip6assign '64'
   option ifname 'eth0.1'

config interface 'wan'
   option proto 'static'
   option netmask '255.255.255.0'
   option gateway '192.168.0.1'
   option ipaddr '192.168.0.22'
   option ifname 'eth1.2'

config interface 'wan6'
   option ifname 'eth1.2'
   option proto 'dhcpv6'
   option reqaddress 'try'
   option reqprefix 'auto'
Connect-Box Konfiguration:


OpenWrt Konfiguration:
1. screen: modem mode -> router erhält /57 und auch die weitere verteilung von ipv6 im netzwerk funktioniert#



2. screen: router mode -> router erhält ein /64, weitere verteilung von ipv6 im netzwerk funktioniert nicht.


zusammenfassung:
imho liegt das problem daran, dass ich im "router-mode" direkt am WAN interface das /64 zugewiesen bekomme ohne prefix delegation und dann kein platz mehr für ein kleineres netz am lan-interface ist.
alternativ kann man das ganze vielleicht im modem mode lösen - nur bekomme ich DS nicht zu laufen. lt. upc hotline, geht das auch nicht (darauf verlasse ich mich aber mal nicht).

tia jedenfalls für input
 

neo1977

Mobilfunk Teilnehmer
17 Aug 2019
4
3
Hallo, hatte auch das gleiche Problem mit fehlender Prefix Delegation. Die Lösung ist ganz einfach: Die WAN und WAN6 auf Standard eingestellt lassen, am besten alles auf Werkseinstellung. Openwrt Router mit dem WAN Port auf den Provider Router (ist wahrscheinlich eine ConnectBox) hängen. Auf der ConnectBox darf kein anderes Gerät mehr angeschlossen sein. Zum schluss muss die ConnectBox auf Werkseinstellung zurückgesetzt werden. Eventuell musst deinen Openwrt Router auch noch mal neu starten. Dann solltest auf der WAN6 ein /60 Prefix bekommen.

Wichtig ist auf der ConnectBox kein anderes Gerät mehr verbinden.

Bei weiteren Fragen einfach melden.
 

laserjet313

Mobilfunk Teilnehmer
15 Aug 2019
3
0
hi - vielen dank für die tipps!

ich hab es gestern kurzzeitig hinbekommen, aber nach dem nächsten neustart von OpenWRT hat es nicht mehr geklappt.

wie hast du die AFTR adresse rausbekommen?
ich habe folgende irgendwo in der connectbox folgenden eintrag gefunden:
aftr01.upc.at - jedoch klappt es nicht wenn ich diese adresse eintrage. ich hab dann zufällig in der routing-table eine IP gefunden mit der es schlussendlich bis zum reboot geklappt hat - kompliziertes thema :/
 

neo1977

Mobilfunk Teilnehmer
17 Aug 2019
4
3
Hab die Connect Box im normalen Router Mode gelassen. OpenWRT auf der WAN Seite alles auf Standard. IPv4 hast dann ein doppeltes NAT (OpenWRT und DSlite). IPv6 bekommst dann auf dem OpenWRT ein /60 Prefix, das heißt vier IPv6 Netze mit jeweils tausenden Clients. 1. Router bekommt automatisch das erste Prefix die restlichen drei kannst dann auch auf andere OpenWRT Router aufteilen. Das mit der AFTR Adresse hatte ich auch mal Probiert, aber ohne Erfolg. Da müsste schon Magenta mitspielen, da du dann OpenWRT mit DSlite konfigurierst.

Die von mir beschriebene Lösung funktioniert schon seit einem halben Jahr ohne Probleme.
 
  • Gefällt mir
Reaktionen: laserjet313

laserjet313

Mobilfunk Teilnehmer
15 Aug 2019
3
0
bisher hatte ich noch keinen erfolg. deshalb eine weitere frage bezüglich Reouter-mode der connect-box:
funktioniert bei dir die Prefix-Delegation im router mode und bekommt dadurch dein LAN-interface ein /64 zugewiesen?

ohne zugewiesenen prefix, weiß ich Nicht wie ich das stabil hinbekommen soll.
ev. kannst du mir bei gelegenheit auch einen screenshot des WAN interfaces zukommen lassen.

tia jedenfalls
 

neo1977

Mobilfunk Teilnehmer
17 Aug 2019
4
3
Die Connect-Box ist im normalen Router Mode. Am WAN Interface von deinem Router bekommst dann eine IPv6 Adresse von der Connect-Box und dann auch ein /60 Prefix. Das funktioniert aber nur wennst die Connect-Box mit dem Reset Knopf auf Werkseinstellung zurück setzt und dann nur mehr deinen Router anhängst.

Werde dann gleich mal ein paar Screenshots machen
 

Aktuelle Themen