Statisches IPv6-Netz mit fonira

Gringo

Mobilfunk Teilnehmer
9 Feb 2017
1.755
1.013
Weiß jemand wie man das mit openwrt einstellt?
Ein Interface wan6 (dhcpv6 client) anlegen welches mit wan (PPPoE client) verbunden ist.
PD-Prefix (jener Prefix der Dir von Fonira zugeteilt wurde) unter "Advanced Settings" als "Custom delegated Prefix" eintragen. Fertig.
Dann sollten alle (Windows10) Rechner dahinter (automatisch) eine Adresse aus dem PD-Prefix-Bereich bekommen.
Wenn nicht (z.B. für Windows7), dann händisch eine IPv6 aus dem Prefix-Bereich vergeben.
z.B. 192.168.0.10 wird dann bei zu IPv6: "prefix::10" usw.
ipconfig /all sollte dann in etwa so aussehen:
Code:
Ethernet-Adapter LAN1:

   Verbindungsspezifisches DNS-Suffix: ***.at
   Beschreibung. . . . . . . . . . . : Intel(R) PRO/1000 PT Dual Port Server Adapter
   Physische Adresse . . . . . . . . : 00-15-17-2E-5D-BD
   DHCP aktiviert. . . . . . . . . . : Nein
   Autokonfiguration aktiviert . . . : Ja
   IPv6-Adresse. . . . . . . . . . . : 2a01:aea0:dd3:fe::b4d(Bevorzugt)
   Lease erhalten. . . . . . . . . . : Freitag, 3. Jänner 2020 11:07:44
   Lease läuft ab. . . . . . . . . . : Mittwoch, 11. Februar 2156 17:45:43
   IPv6-Adresse. . . . . . . . . . . : 2a01:aea0:dd3:fe:1889:2c23:e97a:****(Bevorzugt)
   IPv6-Adresse. . . . . . . . . . . : fd00::1889:2c23:e97a:****(Bevorzugt)
   IPv6-Adresse. . . . . . . . . . . : fdfd:6890:8f9d::b4d(Bevorzugt)
   Lease erhalten. . . . . . . . . . : Freitag, 3. Jänner 2020 11:07:44
   Lease läuft ab. . . . . . . . . . : Mittwoch, 11. Februar 2156 17:45:43
   IPv6-Adresse. . . . . . . . . . . : fdfd:6890:8f9d:0:1889:2c23:e97a:c4ca(Bevorzugt)
   Standortlokale IPv6-Adresse . . . : fec6::6%1(Bevorzugt)
   Temporäre IPv6-Adresse. . . . . . : 2a01:aea0:dd3:fe:513b:7a8e:3b3c:9b82(Bevorzugt)
   Temporäre IPv6-Adresse. . . . . . : fd00::513b:7a8e:3b3c:9b82(Bevorzugt)
   Temporäre IPv6-Adresse. . . . . . : fdfd:6890:8f9d:0:513b:7a8e:3b3c:9b82(Bevorzugt)
   Verbindungslokale IPv6-Adresse  . : fe80::1889:2c23:e97a:****%30(Bevorzugt)
   IPv4-Adresse  . . . . . . . . . . : 192.168.0.6(Bevorzugt)
   Subnetzmaske  . . . . . . . . . . : 255.255.255.0
   Standardgateway . . . . . . . . . : 192.168.0.47
   DHCPv6-IAID . . . . . . . . . . . : 167777559
   DHCPv6-Client-DUID. . . . . . . . : 00-01-00-01-24-AD-3D-9D-00-15-17-2E-5D-BC
   DNS-Server  . . . . . . . . . . . : fec6::9%1
                                       192.168.0.9
   NetBIOS über TCP/IP . . . . . . . : Aktiviert
 
Zuletzt bearbeitet:

fonira

Offizieller Account
8 Feb 2019
978
1.916
Super danke!

Eine Frage noch: gibt es auch IPv6 DNS Server von euch?
Gibt es zu den automatisch zugewiesenen DNS Servern 91.206.8.68 und 91.206.8.80 auch adäquate v6 Adressen?

LG
Martin
Hier die DNS-IPv6 Adressen. Diese könnten sich aber noch ändern in der Zukunft (also einfachere Adressen). Diese werden aber bestehen bleiben.

2a02:1748:0:1500:5::5001
2a02:1748:0:1500:3::3214
 
Zuletzt bearbeitet:
  • Gefällt mir
Reaktionen: mteufel und bissfest

Sin10

Mobilfunk Teilnehmer
23 Mrz 2014
2.615
1.104
Ein Interface wan6 (dhcpv6 client) anlegen welches mit wan (PPPoE client) verbunden ist.
daran scheitert es ja schon bei mir. Ich kann machen was ich will, das ist den relativ egal.
Ich habe

- Schittstelle WAN6 angelegt
- DHCPv6 client ausgewählt
- "request IPv6-adress" => try
- "Request IPv6-prefix of length" => 60

Unter erweitert:
- Custom delegated IPv6-prefix: von fonira zugeteilten präfix reinkopiert mit :: am schluss (2a02:1748:fad4:x:: )

Unter physikalische einstellungen:
- eth1 (WAN)

probiert hab ich hier noch eintragen: @WAN

-Firewall Zone:
- WAN


Schnitstelle WAN (PPoE client) unter erweitert:
- Use builtin IPv6-management den haken drausen
und darunter "deaktiviert"

probiert hab ich hier auch: den haken drin lassen mit manual, und deaktiviert.
gleiches ergebniss


sobald ich aber bei der ppoe verbindung die einstellung
"Use builtin IPv6-management" aktiviere und darunter auf "automatic" stelle bekomm ich sofort das von fonria automatisch zugewießene ipv6 netz 2a02:1748:dd2d:x::/60 (das ist nicht das statische)

Hast vl noch nen tipp für mich?
 

Gringo

Mobilfunk Teilnehmer
9 Feb 2017
1.755
1.013
daran scheitert es ja schon bei mir. Ich kann machen was ich will, das ist den relativ egal.
Ich habe

- Schittstelle WAN6 angelegt
- DHCPv6 client ausgewählt
- "request IPv6-adress" => try
- "Request IPv6-prefix of length" => 60

Unter erweitert:
- Custom delegated IPv6-prefix: von fonira zugeteilten präfix reinkopiert mit :: am schluss (2a02:1748:fad4:x:: )

Unter physikalische einstellungen:
- eth1 (WAN)

probiert hab ich hier noch eintragen: @WAN

-Firewall Zone:
- WAN


Schnitstelle WAN (PPoE client) unter erweitert:
- Use builtin IPv6-management den haken drausen
und darunter "deaktiviert"

probiert hab ich hier auch: den haken drin lassen mit manual, und deaktiviert.
gleiches ergebniss


sobald ich aber bei der ppoe verbindung die einstellung
"Use builtin IPv6-management" aktiviere und darunter auf "automatic" stelle bekomm ich sofort das von fonria automatisch zugewießene ipv6 netz 2a02:1748:dd2d:x::/60 (das ist nicht das statische)

Hast vl noch nen tipp für mich?
Beim WAN6-IF "Request IPv6-prefix of length" auf "automatic". und beim "custom delegated prefix" "2a02:1748:fad4:x::/Prefix Länge" angeben. Dann sollten die Clients im LAN bereits eine IPv6 erhalten.
Auch das IF "LAN" sollte dann eine entsprechende IPv6 erhalten. Siehe untenstehender Screenshot.
Screenshot 2020-01-05 18.38.37.png

Im Moment bekomme ich am WAN6 keine /128 IPv6 zugewiesen, aber das ist ein anderes Problem, das erst morgen vom Provider gefixt wird.
 
Zuletzt bearbeitet:

Sin10

Mobilfunk Teilnehmer
23 Mrz 2014
2.615
1.104
@Gringo meinen router interessiert das gar nicht

hab jetzt von dir angegebene änderungen gemacht, aber bekomm trotzdem kein IPv6 netz zugewiesen.
Hab mich noch etwas gespielt bei ppoe und dem v6 managment - ist ihn auch egal.

screenshot.2020-01-05.png screenshot.2020-01-05 (1).png screenshot.2020-01-05 (2).png screenshot.2020-01-05 (3).png
 

Sin10

Mobilfunk Teilnehmer
23 Mrz 2014
2.615
1.104
hab ich jetzt gemacht, geht trotzdem nicht.

screenshot.2020-01-05 (4).png

was ich jetzt gelesen habe im openwrt forum :
The WAN6 interface is automatically spawned by the PPPoE protocol handler if IPv6 is offered by the PPP peer
Sobald ich das abdrehe und eben versuche das WAN6 händisch anzulegen gehts nicht. Automatisch bekomm ich sofort das dynamische v6 netz

kann ja eigentlich gar nicht so schwer sein, oder doch? :D
 

Gringo

Mobilfunk Teilnehmer
9 Feb 2017
1.755
1.013
pppoe hab ich nicht. Hab hier nur eine echte Bridge zur Fritzbox ohne PPPoE
 

Sin10

Mobilfunk Teilnehmer
23 Mrz 2014
2.615
1.104
ok jetz ist v6 angesprungen. Aber erst nachdem die v4 zugewiesen war und die verbindung ne minute da war. Dann hat ers aufeinmal hinbekommen

allerdings hab ich jetzt das statische UND das dynamische v6 netz am LAN anliegen.
ich lass das jetzt erstmal bleiben und lass mir vom dhcp das dynamische v6 netz geben. Einfach weil das alles andere, nur nicht zuverlässig geht.


wie hast du das mit der bridge gelöst?
 

Aktuelle Themen