Statisches IPv6-Netz mit fonira

A_User

Mobilfunk Teilnehmer
31 Mai 2020
5
1
Ich hatte im folgenden noch folgendes Problem mit meiner Konfiguration: Nach einem Reboot ging nichts mehr. Grund war, dass das WAN interface von pfSense keine IPv6 addresse mehr bekam, dadurch ging auch der DNS resolver (und IPv6 allgemein) nicht. Fixen konnte man das, in dem man LAN wieder auf Track Interface stellt, und dann WAN reconnected. Nicht optimal, nach einem Strom/Internetausfall muss man wieder händisch ran. Nach einigen Google Suchen fand ich heraus, dass andere DHCPv6 optionen genutzt werden wenn man Track Interface verwendet, und man sonst keine Prefix Delegation ersucht. Ich konnte es im Endeffekt mit folgenden Einstellungen beheben. advanced_dhcp_options_pfsense.jpg

Diese Konfiguration funktioniert vorerst auch über Reboots / Powerloss hinweg. Falls sich daran etwas ändert, werde ich mich hier wieder melden, ich hoffe ich kann dem ein oder anderem damit etwas helfen.
 

Sin10

Mobilfunk Teilnehmer
23 Mrz 2014
2.679
1.144
ich bin nach wie vor dafür das man das statische v6 netz mit den login daten hinterlegt. Keine Ahnung wieviel aufwand das ist.
 

dandjo

Mobilfunk Teilnehmer
5 Jan 2015
328
135
Da brauchst du für jeden User einen (virtuellen) DHCPv6. Oder man handelt es über ICMPv6.
 

fonira

Offizieller Account
8 Feb 2019
1.056
2.078
ich bin nach wie vor dafür das man das statische v6 netz mit den login daten hinterlegt. Keine Ahnung wieviel aufwand das ist.
wir haben schon mal evaluiert. Müssten es noch mal austesten mit etwas Zeit. Dafür müssen wir aber die bestehenden Netze für jeden Anschluss in den DHCPv6 laden und konfigurieren. Klar macht das ein Script, wäre machbar, die Frage ist welchen Effekt es auf die bestehenden Anschlüsse hat.
 
  • Gefällt mir
Reaktionen: A_User und Sin10

adiz0r

Mobilfunk Teilnehmer
29 Aug 2020
1
7
Hello all,

I've just registered and this is my first post in this forum. Excuse me for using English, I do not want to tease you with my subpar German. :) I discovered this community a some years ago and already found a couple of great tips here, so I would like to reciprocate and share a working OpenWRT 19.07.3 configuration for Fonira static IP address.

I'm using my own PC Engines APU2C4 router and asked for a Zyxel VMG4005-B50A DSL modem from Fonira to replace the default Fritzbox.

The modem is connected to eth0 on the APU2. Internet traffic flows on VLAN31 (ask Fonira why), and I also set up a static IP on the untagged interface, so I can reach the modem (192.168.1.1) with browser and SSH. All the following code snippets are from /etc/config/network.

Code:
config interface 'modem'
        option ifname 'eth0'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.1.16'
        option force_link '0'
The IPv4 WAN interface is a fairly standard stuff. I'm using my own DNS resolver (Unbound+DNSmasq in chain), so peerdns is 0.

ipv6 is a tricky parameter which still puzzles me. If you set it to 0/no, there will be no IPv6 connectivity. If it's auto, you'll end up with a dynamic address and DP. You need to set it to 1/yes for the next section to work.

Code:
config interface 'wan'
        option ifname 'eth0.31'
        option proto 'pppoe'
        option username 'yourusername@fonira.at'
        option password 'yourpassword'
        option peerdns '0'
        option ipv6 'yes'
Below is the IPv6 WAN interface which I could figure out with a lot of trial and error. This Fritzbox screenshot gave me the idea to try to use the first /64 subnet from the delegated prefix.

What you need to set:
- ifname to '@wan', so it piggybacks the PPPoE link
- ip6prefix to the /60 network address you got from Fonira
- ip6addr to any address you like in CDIR notation in the first /64 subnet, I chose ::1
- and also add a static IPv6 default route pointing to interface wan

Code:
config interface 'wan6'
        option ifname '@wan'
        option proto 'static'
        option ip6addr '2a02:1748:dead:beef::1/64'
        list ip6prefix '2a02:1748:dead:beef::/60'

config route6
        option target '::/0'
        option interface 'wan'
You'll still have 15 /64 subnets for your internal networks which you can set up with the usual ip6assign and ip6hint parameters. Odhcpd will complain in the logs ("A default route is present but there is no public prefix on XXX thus we don't announce a default route!"), but it works.

Example internal interface configuration and how it looks like (I use several VLANs):

Code:
config interface 'dmz'
        option ifname 'eth1.6'
        option proto 'static'
        option ipaddr '172.16.6.1'
        option netmask '255.255.255.0'
        option ip6hint '6'
        option ip6assign '64'

# ip a l eth1.6
7: eth1.6@eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 01:da:da:d1:da:da brd ff:ff:ff:ff:ff:ff
    inet 172.16.6.1/24 brd 172.16.6.255 scope global eth1.6
       valid_lft forever preferred_lft forever
    inet6 2a02:1748:dead:be06::1/64 scope global noprefixroute
       valid_lft forever preferred_lft forever
    inet6 fd00:11:0:6::1/64 scope global noprefixroute
       valid_lft forever preferred_lft forever
    inet6 fe80::678:b8ed:5341:8636/64 scope link
       valid_lft forever preferred_lft forever
#
Finally, I put my 'modem', 'wan', and 'wan6' interfaces into the 'wan firewall zone in /etc/config/firewall:

Code:
config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option network 'modem wan wan6'
Run /etc/init.d/network restart to activate the new network configuration.

I hope I could help others. Let me know if you have any questions.
 

phluko

Mobilfunk Teilnehmer
1 Jul 2019
9
4
wir haben schon mal evaluiert. Müssten es noch mal austesten mit etwas Zeit. Dafür müssen wir aber die bestehenden Netze für jeden Anschluss in den DHCPv6 laden und konfigurieren. Klar macht das ein Script, wäre machbar, die Frage ist welchen Effekt es auf die bestehenden Anschlüsse hat.
Gibts dazu ein Update? Danke!
 

fonira

Offizieller Account
8 Feb 2019
1.056
2.078
Gibts dazu ein Update? Danke!
War das eine freiwillige Meldung zum Test? :)
Grundsätzlich gibt es ein Konzept, das muss aber "da draußen" noch getestet werden.

Der Nachteil ist, dass wir mit dieser Lösung die Daten in den DHCPv6-Server rausschreiben müssen, und wir haben nicht so viel Freude, wenn sich wegen einem Fehler in der Konfiguration dann alle Services verabschieden... Daher muss es sehr sorgfältig gemacht werden...
 

phluko

Mobilfunk Teilnehmer
1 Jul 2019
9
4
War das eine freiwillige Meldung zum Test? :)
Grundsätzlich gibt es ein Konzept, das muss aber "da draußen" noch getestet werden.

Der Nachteil ist, dass wir mit dieser Lösung die Daten in den DHCPv6-Server rausschreiben müssen, und wir haben nicht so viel Freude, wenn sich wegen einem Fehler in der Konfiguration dann alle Services verabschieden... Daher muss es sehr sorgfältig gemacht werden...
Klar, immer gerne ;-)
Oh ja, klingt nach einer Herausforderung die gut getestet sein muss.
 

fonira

Offizieller Account
8 Feb 2019
1.056
2.078
Wie schaut ein ideales Versuchskaninchen aus? PN?
Das wäre dann der Normal-User. :)
Unser gestrige Test war leider nicht erfolgreich, wir müssen einen Parameter am Router ändern und das werden wir zuerst im Testsystem machen. Also dauert es noch ein wenig.
 

Aktuelle Themen