UPC/Magenta Connect-Box rebootet bei Aufruf von wetter.orf.at

16 Mai 2021
23
40
Problem tritt definitiv sowohl mit LAN als auch mit WLAN auf.
Das Timing kann aber einen Unterschied machen, ob Du es über beide Medien provozieren kannst.
 
18 April 2018
1.558
709
Die Connect-Box hat ein generelles Problem damit, wenn mehrere (outgoing) IPv6-TCP-Connections mit gleichem quadruple {source IP address, source port number, destination IP address, destination port number} in zeitlicher Nähe stattfinden. Also: Das Wieder-Verwenden eines soeben genutzten IPv6-TCP-Source-Ports für den nochmaligen Verbindungsaufbau zum gleichen Ziel führt zum Absturz und Reboot.
Hört sich nach einer adäquaten Zusammenfassung an.

Ich gehe davon aus, dass Du damit meinst wenn in schneller Reihenfolge SYN/ACK Handshakes in der Kombi erfolgen. Sollte eigentlich Information gut genug sein, dass UPC mim Debuggen anfangen kann :)
 
20 November 2018
2.020
1.263
Ich versuche den Kenntnis-Stand in einem Satz zusammenzufassen:

Die Connect-Box hat ein generelles Problem damit, wenn mehrere (outgoing) IPv6-TCP-Connections mit gleichem quadruple {source IP address, source port number, destination IP address, destination port number} in zeitlicher Nähe stattfinden. Also: Das Wieder-Verwenden eines soeben genutzten IPv6-TCP-Source-Ports für den nochmaligen Verbindungsaufbau zum gleichen Ziel führt zum Absturz und Reboot.

Ich tippe einmal ins Blaue: Gunnar, Deine Box muss im DS-Lite-Mode ja NAT64 machen. Ich würde auf einen Überlauf dort tippen.
 
Zuletzt bearbeitet:
16 Mai 2021
23
40
@telephon nein, NAT64 kommt keines zum Einsatz.

IPv4 funktioniert im DS-Lite-Modus der Connect-Box über ein CGN von Magenta.
Und IPv6 ist geroutet, hinter dem Modem hat man ein /64 zur Verfügung.

Wie im Blog-Beitrag am Ende geschildert tritt das Problem mit IPv6 und nicht mit IPv4 auf. Kein CGN, kein NAT64.
 
6 Januar 2020
16
26
Meine Connect Box hat gerade das Softwareupdate CH7465LG-NCIP-6.15.28-4p9-NOSH bekommen. Kann das problem aber weiterhin reproduzieren.
 
  • Gefällt mir
Reaktionen: gunnar
16 Mai 2021
23
40
Also, Status-Update: Google Chrome 91.0.4472.77 ist nun dem Beta-Stadium entwachsen, wird seit 25.05.2021 21:00 als reguläres Google Chrome Online-Update verteilt. Problem damit - wie befürchtet - vorhanden. Könnte ab morgen also mehr Anwender geben, die mit dem Problem kämpfen.

Magenta hat sich heute bei mir gemeldet und mitgeteilt "wir schauen uns das an". Seitdem keine Rückmeldung mehr. Mein Blog-Post ist mit den neuen Infos aktualisiert.
 
Zuletzt bearbeitet:
16 Mai 2021
23
40
Status-Update: Magenta hat mir heute mitgeteilt das Problem wäre "an den Modem-Hersteller" weitergeleitet worden. Außerdem hat man mir aufgetragen ich solle doch die Browser-Hersteller informieren. Mir erschließt sich zwar nicht warum das meine Aufgabe wäre, aber weil ich ein guter Mensch bin habe ich mich dennoch durch den Chromium-Source-Code gewühlt und die Code-Stelle ausfindig gemacht und den Entwickler informiert - siehe hierzu meine Blog-Post-Ergänzungen.

Außerdem habe ich herausgefunden, dass z.B. das Installieren von Visual Studio die Port-Range-Konfiguration wie von mir beschrieben abändert, womit wir also einen möglichen Übeltäter gefunden hätten warum z.B. meine Windows-Installation nicht wie eine Default-Installation konfiguriert war.
 

Aktuelle Themen